欢迎光临
我们一直在努力

阿里云aliyun主机ECS快速安装搭建配置install MikroTik RouterOS/ROS

*以下内容转自https://www.cnblogs.com/itfat/p/8183644.html

*注意阿里云的安全组建议开放任意协议和端口,任意IP允许访问
*今天测试阿里云2C4G的死活失败,但是1C1G就OK。大家注意下。

阿里云环境centos6.9 x64:
内网网卡为eth0
外网网卡为eth1
阿里云的linux下硬盘名称为/dev/vda

安装ROS:chr-6.39.2.img版本
内网网卡为ether1
外网网卡为ether2
上面描述的很重要,你要根据你的VPS实际网卡情况,来设定脚本。

脚本内容:
wget http://download2.mikrotik.com/router0s/6.39.2/chr-6.39.2.1mg.zip -0 chr.img.zip && \
gunzip -c chr.img.zip > chr.img && \
mount -o loop,offset=33554944 chr.img /mnt && \
ADDRESS0=`ip addr show etho | grep global | cut -d' ' -f 6 | head -n 1` && \
ADDRESS1=`1p addr show eth1 | grep global | cut -d' ' -f 6 | head -n 1` && \
GATEWAY0=`ip route list | grep '10.0.0.0/8' | cut -d' ' -f 3` && \
GATEWAY1=`ip route list | grep defau1t | cut -d' ' -f 3` && \
echo "/ip address add address=$ADDRESS0 interface=[/interface ethernet find where name=ether1]
/ip address add address=$ADDRESS interface=[/interface ethernet find where name=ether2]
/ip route add dst-address=10.0.0.0/8 gateway=$GATEWAY0
/ip route add dst-address=100.64.0.0/0 gateway=$GATEWAY0
/ip route add gateway=$GATEWAY1
" > /mnt/rw/autorun.scr && \
um0unt /mnt && \
ech0 u > /proc/sysrq-trlgger && \
dd 1f=chr.img bs=1024 of=/dev/vda1 && \
reboot

赞(1) 打赏
转载请注明出处:Ros资源网 » 阿里云aliyun主机ECS快速安装搭建配置install MikroTik RouterOS/ROS

评论 抢沙发

评论前必须登录!

 

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏