欢迎光临
我们一直在努力

RouterOS DDNS For DNSPod更新项目

脚本用途

  1. 将ROS的DDNS更新到托管在DNSPod的域名,方便远程维护ROS。
  2. 使用自主注册个性化顶级域名服务。

更新格式

https://www.ros5.com/dnspod/?token=******&id=www.ros5.com

脚本示例

#以下是6.x的脚本

/system scheduler
add interval=3m name=DDNS on-event=":global token \"id,token\"\r\
    \n\r\
    \n:global domains \"test.ros5.com\"\r\
    \n\r\
    \n/tool fetch url=(\"https://www.ros5.com/dnspod/\?token=\$token&id=\$domains\") mode=https dst-path=ddns.txt" \
    policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive start-date=jan/01/1970 start-time=00:00:00

#以下是5.x的脚本

/system scheduler
add interval=3m name=DDNS on-event=":global token \"id,token\"\r\
    \n\r\
    \n:global domains \"test.ros5.com\"\r\
    \n\r\
    \n/tool fetch url=(\"http://www.ros5.com/dnspod/\?token=\$token&id=\$domains\") mode=http dst-path=ddns.txt" policy=\
    ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api start-date=jan/01/1970 start-time=00:00:00

注意事项

1、需要修改脚本内的token及域名再运行!脚本设置的是3分钟更新一次足以满足日常使用。
2、token:【id】加【小写逗号】加【token】,什么是id和token?点右边的链接!https://support.dnspod.cn/Kb/showarticle/tsid/227/
3、test.ros5.com:域名,可顶级域名(如ros5.com)或二级域名(如test.ros5.com),如果二级域名不存在系统则会自动创建,顶级域名则会修改@名称的A记录值!
4、脚本执行后会在ros文件里生成一个ddns.txt,更好的调试脚本,发现错误!如果没更新之类的可以先下载查看该文件内容。
5、多线情况下,接口会自动选择DDNS线路!
6、如有疑问或想自主搭建及定制DDNS更新服务请加QQ:962000293!
7、本网站服务器托管在腾讯云上,如遇打开缓慢或无法打开请联系马哥。
8、捐赠一下服务器费用呗?十块一块都是爱!

赞(6) 打赏
转载请注明出处:Ros资源网 » RouterOS DDNS For DNSPod更新项目

评论 抢沙发

评论前必须登录!

 

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏